Questions tagged [rpm]

0

votes
0

answer
2

Views

unable to install devtoolset-3 in rhel7 using local repo

I have searched the internet for installing devtoolset-3 and found out to install using the following: 1. On RHEL, enable RHSCL repository for you system: $ sudo yum-config-manager --enable rhel-server-rhscl-7-rpms 2. Install the collection: $ sudo yum install devtoolset-3 3. Start using software co...
js.hrt
0

votes
0

answer
3

Views

RPM Vs Tar based Installation

My knowledge on Linux administration is limited and hence wanted to check here about the pros and cons of installing any RHEL/CentOS Linux software using rpm packages over installing through tar/zip files. Thanks
greenhorntechie
6

votes
0

answer
62

Views

Is there a specification for the YUM metadata?

I'm trying to find a trusted point of truth for the following yum metadata files: primary.xml.gz filelists.xml.gz other.xml.gz repomd.gz groups.xml.gz I've been looking around the Internet, but I haven't found a definitive reference, or guide. Is there a concrete specification, or RFC for this, or i...
carlspring
1

votes
1

answer
649

Views

rpm reduces the size of shared library

I am making an rpm of my shared library. In the .spec file, I am writing the normal install commands in %install part ,making some soft links, running ldconfig on %post and %postun. I am not building library in rpm because I already have compiled and stripped library with me. But it happens that whe...
Jewel Thief
1

votes
1

answer
1.4k

Views

rpmbuild error in temp file

I'm completely new to RPMs and RPM building. Here's the error I get: [[email protected] SPECS]$ rpmbuild -bp pa_connector.spec Executing(%prep): /bin/sh -e /var/tmp/rpm-tmp.71097 + umask 022 + cd /usr/src/redhat/BUILD + LANG=C + export LANG + unset DISPLAY + $'\r' : command not found097: line 27: er...
Hebron George
1

votes
3

answer
922

Views

cpan2rpm does not seem to get installed Perl version

I'm running on RHEL6, with RHEL's perl-5.10.1-130.el6_4 installed. I am trying to build some RPMs using cpan2rpm 2.028. Also, perl-version-0.77-130.el6_4 is installed. It's giving odd failures, saying the installed version of Perl is not new enough: $ perl - This is perl, v5.10.1 (*) built for x86_6...
David Chin
1

votes
3

answer
397

Views

setting error states during Linux RPM install/upgrade

I'm currently developing my first Linux RPM package for release. During the %post hook, I want to ensure that a particular file is resident on the target system. If this file is present, I'd like the install to proceed. If this file is missing, I'd like RPM to abort the install and report an erro...
user1858431
1

votes
1

answer
2.4k

Views

Puppet: removing a package with --nodeps

Is there a method to remove a package without dependency removal? Essentially I would like to do the following command with puppet. rpm -e package --nodeps
user1824727
1

votes
1

answer
875

Views

Give RPM macro an argument with spaces

Example RPM macro: %define hello() \ printf 'hello, %{1}.\\n'; I would like to be able to give it macros with spaces in it, as in: %{hello "Dak Tyson"} -> printf 'hello, Dak Tyson.\n' However, it keeps doing this: %{hello "Dak Tyson"} -> printf 'hello, "Dak.\n' In other words, it doesn't interpret t...
djhaskin987
1

votes
1

answer
1k

Views

What does Illegal char '-' in version executing a maven antrun plugin?

One of my group's pom files uses the maven-antrun-plugin to do an rpm build. I don't know why, and we can't change it for now. The pom has version 1.0.0-Sprint2-SNAPSHOT, and during the build, I get [exec] error: line 2: Illegal char '-' in version: Version: 1.0.0-Sprint2. How can I alleviate this...
Chris F
1

votes
1

answer
1.4k

Views

Building paths in SBT for the packageMappings of the sbt-native-packager

I am very new to SBT and need to create a RPM package for one of my project. The RPM contains only 1 file, which is a one-jar created by the sbt-onejar plugin). I want to use sbt-native-packager plugin and have created a Packagin.scala file under the /project directory like this: object Packaging {...
reikje
1

votes
2

answer
1.9k

Views

How can I upgrade RPM version 4.4.* to RPM version 4.8.*?

I am getting error below when I am trying to install a package on CentOS 5. After some research it seems like my RPM version needs to be upgraded; How can I upgrade RPM version 4.4.2.3 to RPM version 4.8.0? #sudo rpm -ivh test.1.0.0.noarch.rpm error: Failed dependencies: rpmlib(FileDigests)
PMoubed
1

votes
1

answer
7.6k

Views

How to Build RPM of a maven project to be installed on remote systems

I have build a maven project of inventory management on restlet framework and i use MYSQL. Now I need to build a RPM of it so that it works on even remote systems by just installing the RPM
Mragank Tolwani
1

votes
1

answer
1.1k

Views

Building an RPM containing JDK dependency resolution

I'm building oracle jdk 1.6 into an rpm using maven and nexus from a zip file distribution of the jdk. When done, the rpm refuses to install without the following: [[email protected]]# rpm -ivh oracle-jdk-1.6.0_26-1.noarch.rpm error: Failed dependencies: libXt.so.6()(64bit) is needed by oracle-jdk-1.6.0_26...
Jepper
1

votes
2

answer
1.2k

Views

Get return values while extracting the .rpm file

I am allowing the users to upload a .rpm file from my website. I am using sudo rpm -ivh $1 --nodeps command inside a script file to extract .rpm whose name is being passed as parameter. I want to to check that the file user just uploaded and want to install is already there in the system or not and...
Vikas Verma
1

votes
1

answer
180

Views

why isn't rpm release tag redundant?

From rpm .spec file documentation, the version tag is intended to correspond to the version of the software being packaged. But the release tag is intended to increment with a new build of the .rpm. What is the point of the release tag then?? If the software has not changed in the meantime and the...
Mark Galeck
1

votes
1

answer
872

Views

Is there an easy way to build multiple dependent RPMs?

Suppose I have two independent packages A and B where A is dependent on B (A loads symbols from B). Is it possible with rpmbuild to build both packages "simultaneously" so that B's BUILDROOT will be visible to A, or is the best choice to do something like: Build B Install B Build A
PerilousApricot
1

votes
1

answer
120

Views

What does “sdl6” in an RPM package name refer to? [closed]

The specific package I'm referring to is trac-1.0.1-1.sdl6.noarch.rpm. According to this page: http://www.rpm.org/max-rpm/ch-rpm-file-format.html it seems to be part of the package release version. The fact that "sdl" does not appear in my /usr/lib/rpm/rpmrc file also suggests that it's not related...
Dave 114
1

votes
1

answer
983

Views

let rpm %patch not use default --fuzz=0 option

I got error as following in el6 machine: Patch #4 (test.patch): + /bin/cat /path/to/test.patch + /usr/bin/patch -s -p0 --fuzz=0 1 out of 4 hunks FAILED -- saving rejects to file *** 1 out of 1 hunk FAILED -- saving rejects to file *** error: Bad exit status from /var/tmp/rpm-tmp.YeRtKr (%prep) Howev...
xiaochen
1

votes
1

answer
636

Views

Can I invoke functions from an rpm.spec that were declared in dependent RPMs?

Let's say I have an rpm.spec script that builds a MyRPM.rpm package: -- rpm.spec for MyRPM.rpm %define logdir %{my_dir}/logs/%{name} Summary: bla bla bla Name: MyRPM Version: @@@[email protected]@@ Release: @@@[email protected]@@ License: bla Group: Applications/System Requires: That-Other-RPM %description This is m...
theMarceloR
1

votes
1

answer
78

Views

Creating package in mac os x

What is the equivalent of .deb and .rpm in Mac OS X? I am trying to create a package in Mac OS X which will include necessary libraries and scripts.
newbieMACuser
1

votes
3

answer
445

Views

How to add files in the RPM package of an Sailfish OS project?

I am trying to build a Sailfish OS app, and I need to use *.wav files, which are to be distributed through the *.rpm package. In my case, these files are to be put in /usr/share/[application_name]/sounds/*. How do I set up the *.pro and *.yamp files accordingly?
Ivan Bratoev
1

votes
1

answer
2.6k

Views

How do I set optional configuration files in an RPM SPEC file?

Is there a way I can flag a configuration file as optional so when verification is invoked (rpm -v), it will ignore a missing configuration file? I have an RPM package which I include a default configuration file for my application. The configuration file is not required for my application but I'd l...
jdknight
1

votes
1

answer
369

Views

RPM command repeatedly asking for password

I am signing a big set of RPM packages (50000) using the below command find $1 -name \*.rpm |xargs rpm --resign As part of the RPM command structure, it asks for password. I am using expect script for supplying the password, like this. expect -c " spawn $1 expect \"Enter pass phrase: \" send $2\r in...
Srikanth
1

votes
2

answer
1.1k

Views

bash: using expect to automate GPG signing

I am writing a bash script that automates the signing of RPM packages in a YUM repository. To accomplish this task, I use expect. Here is my source code so far: /usr/bin/expect
scottyseus
1

votes
1

answer
1.5k

Views

rpmbuild can't find the files I unpack from source

I am building a custom package which for the most part has a couple of dependencies and install my own files and scripts. I have those files in a tar file and after attempting the build I can see those files unpacked in the rpmbuild/BUILD directory. However there seems to be a problem with the %file...
eignhpants
1

votes
1

answer
85

Views

How to make rpm spec that moves files that were previously marked as %config?

The problem I'm trying to solve is following: In older releases of my package there were config files placed at /srv/product/ dir. %config /srv/product/conf1 %config /srv/product/conf2 But in next upcoming release I removed these conf files from the package. In case if user upgrades the package with...
frizz
1

votes
2

answer
1.7k

Views

RPM spec %post doesn't execute in rpmbuild

Given the minimal RPM spec file, that should only execute a %post stanza: $ cat ~/RPMBUILD/SPECS/test.spec Name: None Version: 1.0 Release: 1 Summary: Bla License: Proprietary %description Bla %prep %build %install %clean %post echo ">>> Inside post
boardrider
1

votes
1

answer
1k

Views

Specified Provides version in rpm spec file

What happend: I'm now working on a linux side-by-side installation issue since rpm no longer support to install the 32-bit and 64-bit same name packages on a machine at the same time. So I need to change the name of the 32-bit package from xxx.i386.rpm to xxx-32bit.i386.rpm. For supporting the upgra...
FPanda
1

votes
1

answer
2.9k

Views

How to define a variable in RPM specs?

How to define a variable in RPM specs? I have 14 folders to create in the RPM and I am creating by following command: mkdir -p /opt/{Folder,Names,Are,Pretty,Cumbersome} My plan is to declare a array variable for all the folders.
Balasekhar Nelli
1

votes
1

answer
564

Views

Why rpm told me the package is installed and not installed?

I tre to uninstall but rpm told me the package is not installed # rpm -e *.rpm error: package ansible-2.0.1.0-2.el6.noarch.rpm is not installed error: package libyaml-0.1.3-4.el6_6.x86_64.rpm is not installed error: package python-babel-0.9.4-5.1.el6.noarch.rpm is not installed error: package python...
wener
1

votes
2

answer
404

Views

rpm install file exist issue

There is a question about install rpm. When I install rpm file rpm -ivh myrpm.rpm sytem wil show error: Failed dependencies: libapr-1.so.0()(64bit) is needed by myrpm but when I check system using locate locate libapr-1.so.0 /usr/lib/libapr-1.so.0 /usr/lib/libapr-1.so.0.3.9 file seems exist Any ide...
Eric Wu
1

votes
2

answer
504

Views

Debugging RPM scriptlets with -x

Is there a way to get /bin/sh -x style output from RPM while it's running a scriptlet? I would like to debug RPM installations.
ldrg
2

votes
1

answer
2.2k

Views

Maven RPM Plugin does not generate the scriptlets specified

I am trying to create an rpm package with the help of the rpm-maven-plugin. All goes well until I try to have it generate the %pre scriptlet (or any scriptlet for that matter) The pom.xml excerpt is: org.codehaus.mojo rpm-maven-plugin 2.0-beta-2 attached-rpm Copyright 2010 XXX, Inc. All rights reser...
Yaneeve
2

votes
1

answer
2.3k

Views

rpmbuild: how to build the package without %install?

I am trying to build a rpm but unfortunately in my build machine I only have limted permission, which means the operation in %install can't be done inside the build machine. How to build the package(.rpm file) without running %install section? It looks like that no options are available for this pur...
Bin Chen
3

votes
2

answer
5.9k

Views

How to install GNU parallel (noarc.rpm) on CentOS 7

I want to install GNU parrallel on Centos 7 There is not much info to find. Can someone explain me how to do this? This is some useful info I found
1

votes
1

answer
18.5k

Views

RPM build errors:Bad exit status from /var/tmp/rpm-tmp.32XJLX (%install)

Im trying to create a simple rpm package on centos 6.5.. But i cannot finish it as its giving me errors.. I have already followed these two threads.. Bad exit status from /var/tmp/rpm-tmp.b1DgAt (%build) and Bad exit status from /var/tmp/rpm-tmp.ajKra4 (%prep) .. yet no luck... I cannot figure out...
Aravinda
1

votes
2

answer
4.4k

Views

Create symlink in RPM

I have a specific version of a software on Linux and I am packaging a .jar file (meant to upgrade the existing software) in an rpm and then trying to re-create a symlink to point to the latest version of the jar. I tried using %post and %postun to create and delete the symbolic link (in case it exis...
Arani
2

votes
2

answer
1.9k

Views

How to find rpm prefix after installing the rpm package

I have installed a rpm package using command "rpm -ivvh --prefix=/home/mypkg package_name ".After installing i need to find the prefix value .How i can do that?
rahul
2

votes
2

answer
8.6k

Views

Building with rpmbuild under Ubuntu

I need to build yum with a patch under Ubuntu 10.4 (reason being that i need a yum with chroot support for my vserver instance) Since yum src for ubuntu where not avaliable (3rd party repos) i downloaded the source off the official repos and the patch off the linux-vserver. However, when i try to b...
Redconnection

View additional questions

Смотреть фильмы онлайн бабушка легкого поведения 2 фильм бесплатно